---
title: "Working with Table Information"
canonical: "https://docs.infoblox.com/space/netmri761/1056867638/Working%20with%20Table%20Information"
format: markdown
---
> Macro (anchor)

> Macro (anchor)

> Macro (anchor)



> ⚠️ Table rows in NetMRI frequently provide sets of icons for editing, exporting, and deleting relevant table records, among other functions. For a closer look at record editing functions in NetMRI tables, see the [*Icons and Popup Windows*](https://infoblox-docs.atlassian.net/wiki/spaces/netmri761/pages/1056867483) topic.

Most NetMRI tables are highly customizable. You can perform the following functions with the tables:

- Select multiple table rows for modification or deletion, select multiple pages from a table, and select all rows/table records for any table.
- Sort, reorder, and resize columns, and show/hide columns.
- Refresh to display changed data.
- Filter tables to sift through quantities of data and locate desired data records.
- Create and apply views, so you can quickly recreate a particular table layout.
- In tables listing issues, you can filter by issue activity type.
- Perform a quick search in a table, and jump from IP address hyperlinks to frequently accessed destinations.

# > Macro (anchor)

> Macro (anchor)

Sorting Table Data

To sort rows based on the contents of a column (method 1): 

1. Click the column heading.
2. Click the heading again to sort in the other direction. The sorted column will have an arrow indicating sort direction.

To sort rows based on the contents of a column (method 2):

1. Hover over the heading for the column to sort, then click the down arrow at the right end of the column heading.
2. In the drop-down menu, click **Sort** **Ascending** or **Sort** **Descending**, as desired. You can sort one column at a time.

To hide or show columns, perform the following:

1. Hover over any column heading, then click the down arrow at the right end of the column heading.
2. In the drop-down menu, hover over **Columns**.
3. In the **Columns** submenu you can perform the following:
  - To hide a column, uncheck the chosen column.
  - To show a column, click the checkbox for the chosen column. At least one column must remain visible in any table.
  - To resize a column, in the table heading row, hover over the column border, then drag the border left or right.
  - To reorder a column, in the table heading row, drag the column heading. (Blue arrows indicate where the column is inserted.)

# > Macro (anchor)

> Macro (anchor)

Selecting Table Data> Macro (anchor)



In a table, NetMRI displays data on multiple pages when the number of items to be displayed exceeds the maximum number of items that can appear on one page. Use the navigational buttons at the bottom of the table to page through the display.

You can select multiple rows in a table. For example, in a Windows browser, you can perform the following to select multiple rows:

- Click the checkboxes adjacent to each other to select contiguous rows.
- Click the checkboxes for any row, separated by any number of rows, to select multiple non-contiguous rows.
- Click the checkbox in the **Select** column of the table header to select all rows on a page, as shown in the figure.

When you click the checkbox in the **Select** column of the table header, in a table that contains multiple pages, only the rows on the current page are selected. All selected rows are greyed out on the table page, denoting their selection. After you select all rows on a page, you can deselect a specific row by clearing the checkbox for the row. The remaining table rows remain selected.

> ⚠️ The table will not preserve selected rows when you navigate to the next page in the table and then return to the current page.

For some tables, the **Select** checkbox is to the left of an Action icon. When you select multiple rows of a table, the Action icons are disabled and the Delete button activates. The **Delete** **list** option is the only available option after selecting multiple rows. Doing so enables you to delete all selected records from the table. Exercise caution when performing this action, as you may unintentionally delete rows of data that you did not wish to select. Note that NetMRI user accounts with read-only privileges will not be able to perform this action.

# > Macro (anchor)

> Macro (anchor)

Filtering Table Data> Macro (anchor)



Use a filter to restrict a table to items of most interest. Filtering operates on specific table columns using operators (such as "=" and "<" for numbers, and "doesn't contain" and "starts with" for strings) and values you specify. You can simultaneously filter multiple columns using terms unique to each column.

To filter a table, perform the following:

1. Click the **Filters** button above the column headings. The **Filters** dialog box appears.
2. Open the **Select** **a** **new** **field** list, and click the name of the column you want to filter. This creates a new row in the dialog box.
3. In the new row, open the **Operator** field, then click the desired operator.
4. In the **Value** field, type the value for the filter (values are case-sensitive).
5. To see how the filter affects the table, click **Apply**.
6. Click **OK**. The table is now filtered according to your specifications.

Filter terms can include regular expressions. Any characters between two forward slashes ("/") are interpreted as a regular expression.

To edit or delete a filter, perform the following:

1. Click **Filter**.
2. In the **Filters** dialog, click the **Delete** button for the term you want to delete. Note that there is no confirmation.  
**Note: **To fully remove a filter and return the table to its unfiltered state, you must delete all filter terms.
3. To see how the change affects the table, click **Apply**.
4. Click **OK**.

# > Macro (anchor)

> Macro (anchor)

Saving Table Views

You can save customized > Macro (anchor)

table views for future use. A table view saves the current state of a table, including column show/hide state, column order, column size, sort order, and filter (but not quick searches).

> ⚠️ All NetMRI users share the same views. New views, for example, are available to all users, and deleting a view makes it unavailable to all users.

To save a table view, perform the following:

1. Set up the table the way you want by applying a filter and/or showing/hiding columns.
2. Click the **Views** button (above the column headings), then click **Add** **view** in the drop-down menu. The **Add** **View** dialog appears.
3. Enter a name for the view (required).
4. Enter a description of the view (optional).
5. To designate this view as the default for the table, click the **Default** checkbox.
6. Click **OK**. The view is now listed in the **Views** menu.

To apply a view, click **Views**, then choose the desired view in the drop-down menu.

> ⚠️ If you apply a view, then modify the table (e.g., rearrange columns), the changes are not saved for that view. To save the changes, you must create a new view.

To edit or delete table views, complete the following:

1. Click the **Views** button and then select **Manage** **view** in the drop-down menu.   
The **Manage** **View** dialog box appears.
2. In the **Manage** **View** dialog box, do one of the following:
  - To modify a table view, click the view, then click the **Modify** button. In the **Modify** **View** dialog box, change the view parameters (name, description, and whether it is the default), and then click **OK**.
  - To delete a table view, click the view, then click the **Delete** button (there is no confirmation).

# > Macro (anchor)

> Macro (anchor)

Issue Table Filtering> Macro (anchor)



Issues tables allow filtering by the issue activity type.

To filter the issues table by activity type, perform the following:

1. Click the **Display** menu (above the column headers).
2. In the submenu, click the activity type you want to see in the table. See the following types:
  - **All:** Displays all issues that existed during the selected time period. This is an important view for real-time analysis because if an issue existed at one point in the day, but was later automatically cleared by NetMRI, it will be listed by selecting **All**.
  - **Current** (default): Displays all issues open for the selected time period, or all issues open at the end of the selected time period if before today.
  - **New:** Displays all new issues during the selected time period.
  - **Cleared:** Displays all issues that have cleared instances during the selected time period.
  - **Suppressed:** Displays all issues that have suppressed instances during the selected time period.

# > Macro (anchor)

> Macro (anchor)

Quick Searching Within a Table> Macro (anchor)



Quick searching enables you to reduce the number of rows in a table by typing a few characters. NetMRI displays the rows for which it finds a match in any column. Quick searching is dynamic, so you can change the search term and immediately see the results.

To perform a quick search, in the **Quick** **Search** field, type at least three characters of the search term (or enter one or two characters), then press **ENTER**.

> ⚠️ You can enter regular expressions in the **Quick Search** field. Any characters between two forward slashes ("/") are interpreted as a regular expression.

To clear quick search results, delete the entry from the **Quick** **Search** field.

NetMRI provides an alternative search tool called FindIT, which allows users with limited access rights to search for information on the system. For more information, see [*Using FindIT for Limited-Access Applications*](https://infoblox-docs.atlassian.net/wiki/spaces/netmri761/pages/1056867665).

# > Macro (anchor)

> Macro (anchor)

Exporting NetMRI Table Data> Macro (anchor)



You can export data from any NetMRI table displaying the **CSV** **Export** icon. Exported data is in standard comma-separated values (CSV) format. You can view exported data in a text editor or a spreadsheet program such as MS Excel.

To export data, perform the following:

1. Click the **CSV** **Export** icon.
2. In the resulting dialog, open the file or save it to disk.

MS Excel can display the first 65,536 rows of data in a large data set.